Error BD - lang_constants and latin1_bin

Hi. Download the program files (v2.0.0) , then upload them by ftp to my hosting account. Then create the database, relate the user, etc. Then I ran the installation. Apparently it installed well but when entering the site and with a couple of clicks on some options the following error is displayed:

ERROR: query failed: SELECT * FROM lang_definitions JOIN lang_constants ON lang_definitions.cons_id = lang_constants.cons_id WHERE lang_id =? AND constant_name =? LIMIT 1

Error: Illegal mix of collations (latin1_bin, IMPLICIT) and (utf8_general_ci, COERCIBLE) for operation ‘=’

/home//public_html/ehr2/library/ at 36: sqlStatementNoLog*

/home//public_html/ehr2/library/ at 2830: xl (Māori)*

/home//public_html/ehr2/interface/super/edit_globals.php at 35: require_once (/home//public_html/ehr2/library/

Please help.

Thank you.

Hi @johnet how did you create your db? Which Database encoding did you use. Please use utf8 or utf8mb4 .

Thanks, Mua

Hi. I use cpanel to create the DB. Then I simply ran the installer that the program brings. Look … I attach 4 images about it.

4 images

@johnet the db supports the default coalation which is in English. Please use utf8_general_ci or utf8mb4_general_ci . It is normal that you have that error since you chosed Latin (spanish_ci) coalation instead of English. I will advice you drop all tables and create a new one choosing the correct database encoding else you can convert back to the utf8 general using ALTER TABLE tbl_name CONVERT TO CHARACTER SET latin1 COLLATE 'latin1_spanish_ci'; but this will have to be done for all the tables. Hope it helps

Thank you. Well finally I had to start the installation from scratch. The first thing was to create the DB from cpanel. Then BEFORE starting the installation, enter phpmyadmin, then access the DB and from the “Operations” option change its collation to utf8mb4_general_ci. After this if you start the installation with setup.php. :wink: